Embarcadero RAD-Studio / Delphi 10.1 Berlin – Erste Eindrücke (2)

Die Installation verlief reibungslos und schnell, genauso die erste Reorganisation der IDE, insgesamt positiver Eindruck.

Aber dann sind mir auch gleich folgende Probleme / Ungereimtheiten mir aufgefallen:

  1. Die Installation des Android SDK erfolgt nicht im SDK Verzeichnis wie unter 10.0 sondern im CatalogRepository ?
    Wohl eine Folge davon, das der SDK jetzt mit GetIt installiert wird. Wozu dann dann noch der SDK Pfad ?
  2. „Codesite Express“ lässt sich nicht installieren, da schon unter 10.0 die Vollversion installiert ist.
    Damit fällt ein integraler Bestandteil meiner Toolchain erstmal weg, mehr als unangenehm !
  3. Options Dialog: Wieso braucht der Dialog > 3 sec zum Öffnen ?
    Und wieso muss ich einen Bibliothekspfad manuell für jede Platform eintragen ? Warum gibt es z.B. keinen „globalen“ Basispfad für alle Plattformen oder VCL/FMX?
  4. Wieso bitte wird noch in iOS 64 und 32 Bit unterschieden ?
  5. GetIt: Alle Bibliotheken werden als xxx230.bpl installiert ?
  6. Hilfe und Realität: Es wird geschrieben, dass es die FireUI App Preview für iOS und Android gibt, aber keine Links – und im App Store schon mal nichts zu finden, sucht man im Internet,  findet sich nur der Hinweis / Link auf die Android App – also ein gross angepriesenes Feature,  ohne iOS erstmal wertlos. Mangelhafte Zeitplanung ?
  7. Liste dann hier auch nochmal das nutzlose Migrationstool für die IDE Settings.

Bei den Kleinigkeiten, bei den Feinheiten, da hat hapert es gewaltig, IMHO hat man bei Embarcadero im Delphi Team das vollkommen aus den Augen verloren, es geht wohl nur noch um neue tolle Features und damit um Umsatzsteigerung. Die IDE hat sich für mich einfach schon lange nicht mehr „rund“ angefühlt.

Mal ehrlich, bei den (Luxus)Preisen, die Embarcadero aufruft, erwarte ich ein besseres „Polishing“. Da es ist dann auch kein Wunder, wenn „alte“ Delphianer wie meiner einer sich intensiv mit Alternativen befasst, sei es RemObjects oder Xamarin oder gar native IDE’s.

Aber nun geht es weiter mit den Tests.

PS: Das tut richtig weh ! Delphi 10.0 Seattle lässt sich nicht mehr starten, sondern bricht mit einem Runtime error ab !!!